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1. Introduction
HoudahSpot is a powerful file search utility. It builds upon the existing Spotlight engine. 
This allows for fast searches without the need for another index. HoudahSpot works 
both as an everyday replacement to the default Spotlight interface and as a power 
search tool.

HoudahSpot makes it easy to create queries and narrow down the search to get to the 
files you are looking for: Find files by name, text, kind, date, tags, pixel count, author, 
recipient, etc. There is a myriad of criteria, which can be combined into groups (“NONE/
ALL/ANY of the following are true”). You can search several locations at once, as well as 
exclude others.

HoudahSpot works at your pace: Set up your search. Click the start button. Only then 
will HoudahSpot get busy gathering results.

Exploring results is easy: You can add any number of columns to the results list. Sort by 
these columns. Examine the result files by previewing text content, file metadata or by 
using the Quick Look feature.

With HoudahSpot, you can find files you forgot you had: pictures that pre-date Apple 
Photos and iPhoto, MP3 files you never put into iTunes, data you carried over from your 
previous Mac and never bothered to sort into your new folder structure. By combining 
modification date, file type, and location criteria, such files are finally within reach.

2. What’s new in HoudahSpot 5
With the HoudahSpot 5 upgrade, we refined just about every aspect of the file search 
experience. Lots of small improvements will have you find files faster. Many operations 
now need fewer clicks. HoudahSpot has more customization options so it can adapt to 
your workflow.

It is now easier than ever to personalize your default search setup. To customize the 
way new HoudahSpot windows are set up, you just need to set up a search with its 
criteria, locations, and result display option and then select File > Save as Default. New 
in HoudahSpot 5, you can now make incremental adjustments to the default set up. For 
example, when you manage search locations, you will have the option to apply your 
changes to the default setup.

HoudahSpot 5 adds support for modern macOS features like dark mode, Touch Bar, 
Finder extensions, and Quick Actions.
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2.1. Folding Text Preview
Quick Look and Text Preview let you peek inside found files without having to open 
them. HoudahSpot’s Text Preview has the unique ability to highlight text you searched 
for.

You can now “fold” the preview to show only text close to highlighted matches. This 
makes it easier to see the context in which the text was found. You may even be able to 
pick up the information you are looking for right from the preview. 

2.2. Recent search attributes & values, locations, and 
columns

HoudahSpot now remembers which search criteria and columns you recently used. It 
will include these in the respective menus without you having to explicitly customize your 
search setup.

HoudahSpot also considers it likely that you will want to use the same attributes in 
search criteria and result columns.  E.g. when you search for photos by “ISO Speed”, 
you will probably want to see the ISO speed values in search results. HoudahSpot thus 
automatically includes “ISO Speed” in the menu of available search result columns.

Similarly, HoudahSpot remembers which locations (folder and drives) you have recently 
searched and includes these in the search and exclusion location menus.

For search criteria where HoudahSpot can offer a list of possible values, it now lists 
recently used values first.

2.3. Quicker criteria setup
While entering criteria values in the Refine pane, you can press Command-Option-
Return to add another criterion for the same attribute. For example, when searching for 
file names that contain both “Houdah” and “Software”: Fill in the “Name” criterion by 
typing “Houdah”. Then press command-option-Return to get a new row. Then type 
“Software”.

Hold the Shift key to duplicate the current criterion and keep its value. This is useful 
when searching for the same text in different attributes. To search for a mail message 
where either the “Authors” or the “Recipients” contain “Houdah”, create an “Any of the 
following is true” group with an “Authors” criterion. Fill it in by typing “Houdah”. Then 
press Command-Option-Shift-Return to duplicate the row. Change the attribute of the 
new criterion to “Recipients”.
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2.4. Arrange search results by kind, date, file size, or 
application

HoudahSpot can now arrange search results in groups by kind, date, file size, or 
application. For example: files that will open in Microsoft Word in one group, and files 
that will open in Apple Pages in another. 

The “Arrange By” option is available from the View menu. Like the column configuration 
and sort options, this setting is saved when creating a default setup or search template.

2.5. Compact Mode
When dragging files from HoudahSpot to other applications, the HoudahSpot window 
may get in the way and obscure the location where you want to use the files. Compact 
Mode shrinks the HoudahSpot window to show just the search results and free up as 
much screen space as possible.

Compact mode can be activated from the View menu or using the “Compact Mode” 
button in the window toolbar. HoudahSpot automatically exits compact mode when you 
open the Search or Details panes.

2.6. Vertical layout
HoudahSpot uses a three-pane layout: Search, Results, and Details. By default, these 
show next to each other. If you need to save horizontal screen space, you can have 
HoudahSpot show Details below Results. This vertical layout is particularly useful when 
using the macOS split screen feature to show two applications side-by-side. 

The layout can be adjusted from the View > Details menu.

2.7. Enhanced grid view
Grid view not only looks nicer, it can also show pertinent file information alongside file 
icons or previews. Two lines of text below the file names show the most relevant 
properties of the file. What information is shown depends on the file type. E.g. for mail 
messages, this will be the sender and recipient.

The “File Info” option can be enabled from the View > Grid menu.
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2.8. Faster file tagging
The file tagging window now lists favorite and recently used tags. 

In HoudahSpot > Preferences > Tags you can now set up keyboard shortcuts to add or 
remove tags from selected search results.

2.9. Fewer windows
When you start a new search, you may want to close earlier searches that you no longer 
need. The new File > Revert lets you start over with a fresh search within the same 
window. The new search will use the same search template as the original search.

3. HoudahSpot and the Spotlight Index
HoudahSpot builds upon Spotlight, which comes preinstalled with macOS. With 
HoudahSpot, there is no need to build an additional index. 

The Spotlight index gets its information from Spotlight importer plug-ins. For standard file 
formats, these plug-ins are provided by Apple. Third-party developers need to provide 
their own Spotlight plug-ins if they want their proprietary file formats to be read by 
Spotlight. Developers are free to decide what information to share with Spotlight and 
how to label it; e.g. one mail client may store the sender’s name as “author” while the 
other labels it “sender”.

You can use the Info pane in HoudahSpot to see which metadata has been recorded for 
a given file, e.g. what information is available for messages from your mail client. 

Therefore, which files HoudahSpot can find and the information that it can display 
depends on the applications you have installed and their respective Spotlight plug-
ins.
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4.  Workflow

HoudahSpot opens to a new search document consisting of three panes: Search, 
Results, and Details.

The Search and the Details panes can be hidden using commands from the View menu. 
Also, the panes can be rearranged so that the Details show below the Results.

4.1. The Search Field
You can start a search by entering search terms into the search field in the window’s 
toolbar. 

The descriptions and instructions in this chapter assume that you have not made any 
adjustments to the default setup.
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HoudahSpot will search for files where all the search terms entered can be found 
anywhere in name, text content, or other metadata. The menu on the loupe icon lets you 
decide if HoudahSpot should search by “Any Text” (the default behavior), “Name”, or 
“Text Content”.

You can start the search by clicking the start button to the right. Alternatively, you may 
continue to refine your search by adding criteria in the Search pane and by specifying 
search locations before you hit the start button.

The search field can also be used to formulate more complex searches.

4.2. Refine Search
Below the search field, you will find the “refine search” area with criteria rows. This 
section allows you to narrow down the search. Criteria rows are typically made of three 
items:

• To the left is the criterion attribute pop-up menu (e.g. Name, Text Content)
• This is usually followed by an operator pop-up menu (e.g. contains, is)
• Last is the criterion value. This may show as text field, pop-up menu, or date picker

The “–” and “+” buttons to the right will add or delete criteria rows. The last button  
creates a criteria group. Criteria rows can be rearranged by drag-and-drop. Hold the 
Option key while you click to grab the criteria rows more easily.

The Search pane may be hidden by clicking the respective view 
selector button in the toolbar or by using commands from the View 
menu. There, you can also opt for the Search pane to hide 
automatically after clicking the start button and to show automatically after clicking the 
stop button.

Click and hold on the Results or Details buttons to see a menu with options for the 
respective panes.
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4.2.1. Criteria Attributes
The Refine section is preconfigured with the following criteria attributes:

■ Name: Matches files by Display Names and Alternate Display Names
■ Text Content: Matches files by indexed text content
■ File Extension: Matches the file name extension
■ Content Kind: Matches files by kind category

Use the pop-up menu to get access to additional attributes. 

You can configure HoudahSpot to list your preferred attributes. HoudahSpot will 
automatically list recently used attributes.

Choose “Other …” to get a list of all criteria attributes available.
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To add an attribute from the list to the pop-up menu, double click the row. Or check the 
“In Menu” option to add an attribute without immediately using it. The attribute will be 
added to every pop-up menu of your current search document. To delete the attribute 
from the list, untick the checkbox.

If you want your selection of menu items to apply to every new search window, click the 
“Update Menu in Default Setup”. To further customize the default setup, use the “Save 
as Default” command from the File menu.

HoudahSpot relies on Spotlight to find files by properties and metadata. The values of 
these attributes are provided by the file system and by third-party Spotlight plug-ins.

4.2.1.1. “Name”
HoudahSpot's “Name” attribute is a combination of two Spotlight attributes: It searches 
both “Display Name” and “Alternate Display Names”. 

The ”Display Name” is typically the same as the file's name or name without extension. 

But: “Display Names” may differ from actual file names. One notable example is Apple 
Mail. It saves messages in numbered .eml files. The message subject is stored as 
“Display Name” with Spotlight. E.g. the file name of a specific mail message file is 
”396936.emlx”, while its “Display Name” will be the mail subject string (e.g. “Re: Try 
HoudahSpot to find files”).

The “Name” criterion can have different operators, of which is / is not will only find exact 
matches of the search terms entered. It will ignore case differences and umlauts. E.g. a 
search for “Name is tree house” will return files like “tree house.jpg”, “tree house.pdf” 
etc., but NOT “my tree house.jpg”.

Criteria are active only when they have been given a value. Thus, you may safely do 
a search on file name by only filling in the matching field. Other criteria are ignored. 
There is no harm in leaving blank criteria in place.
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When the search operator is set to contains, it will return all files which include the 
exact search term entered. It will ignore case differences and umlauts. E.g. a search for 
“Name contains tree house” will return files like “tree house.jpg”, “my tree house.pdf” or 
“tree houses.jpg”, but NOT “tree.jpg” or “house.pdf” (because ALL of the search terms — 
both “tree” and “house” have to be present in the file name for it to be included in the 
results list.)

4.2.1.2. “Text Content” and “Any Text”
The “Text Content” attribute allows you to search files by indexed text content. As such, 
it applies only to files that contain text. E.g. word processing documents, presentations 
etc.

The “Any Text” attribute matches any attribute containing text. E.g. author, location, tags, 
comments, etc. This also includes “text content.”

The available operators apply as follows to a search string of “tree house”:

■ “contains prefixes” searches for starts of words. The example matches “tree 
house”, “TreeHouse” and also “treetop house”

■ “contains words”  searches for words in the text content. The example matches 
“tree house”, “TreeHouse”, but not “treetop house”

■ “contains phrase”  searches for the exact string. The example matches only 
“tree house”

■ “contains all” searches for individual string elements anywhere in the text. The 
example matches files that contain both the words “tree” and “house”, including 
word combinations such as “houseboat” and “appletree”

4.2.1.3. “Content Kind” and “Content Type”
The “Content Kind” attribute matches files by general kind. HoudahSpot provides a list of 
pre-defined types. 

Switch to “Kind” or “Content Type” (via “Other …” in the attribute pop-up menu) for finer 
control. 

“Kind” is a plain language description of the file type (e.g. “Microsoft Word document”)

“Content Type” matches files by Uniform Type Identifier UTI (e.g. “com.apple.mail.emlx”)
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4.2.1.4. “File Extension”
The “File Extension” searches file names for the specified extension. E.g. “txt”, “docx” 
etc. It is a convenience criterion equivalent to searching for file names ending with a dot 
followed by the specified extension. 

4.2.1.5. “Keywords & Tags”
The “Keywords & Tags” attribute is a combination of existing attributes. It searches 
Finder Tags, OpenMeta Tags, and Keywords.

4.2.1.6. “Created”, “Modified”, and “Last Opened"
These attributes match files created, modified, or last opened “before”, “on”, or “after” a 
given date. Using the “within last” operator, it searches for files where the date on the file 
falls during a period of time ending today. You can also search by dates that fall in a 
specific year or month.

Find UTIs hard to remember? Try “Find by Example”:
Drag a file of the content type desired from the Finder or from the HoudahSpot 
results list and drop it onto the “Content Kind” criterion. It will adapt to match the file.
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4.2.1.7. “File Size"
This attribute allows you to search for files of a size equal to, larger, or smaller than a 
value you specify in KB, MB, or GB.

To the Spotlight index, folders have no file size. I.e. Spotlight does not keep track of the 
compound size of all files within a folder. Thus, it is not possible e.g. to search for large 
folders.

HoudahSpot can, however, compute the “Total Size” of folders and show that in the list 
of results. Since HoudahSpot has to explore the contents of each folder and its sub-
folders, these values may take a moment to appear. You can then sort search results by 
“Total Size” to find the larger folders.

4.2.2. Using the Asterisk (*) Wildcard 
You can use the asterisk symbol * as a wildcard. The asterisk * matches any number of 
characters.

Examples:

• A search for the name criterion “*houdah” matches all files beginning with any number 
of unspecified characters followed by “houdah”.

• A search for the name criterion “houdah*” matches all files beginning with houdah 
followed by any number of unspecified characters.

• A search for the name criterion “*.txt” will find all files ending in .txt

The use of the asterisk symbol as a wildcard means that you can not search directly for 
it, therefore:

• If you want to search for *, type \* 
• If you want to search for \*, type \\*
• If you want to search for \, type \

4.2.3. Combining Criteria: ALL / ANY / NONE Groups
The last button in each criterion row creates a criteria group. Groups combine 
several criteria using boolean operators: “ALL / ANY / NONE of the following are 
true”.

By default, files have to match all criteria listed to show up in the results list. The same is 
true for criteria wrapped in an ALL group. Within an ANY group, a file will be found if any 
of the listed criteria match. The criteria nested within a NONE group will be excluded 
from the search.
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Criteria rows can be dragged and dropped into a group. Hold the option key while you 
click to grab the criteria rows more easily.

Examples:

If you want to find files that contain “house” in the name, 

• that have been modified within the 
last 3 days AND are word 
processor files, wrap “Modified 
within last 3 days” and “Content 
Kind is Word Processing” in an 
ALL group (default).

• and are either image OR video 
files, wrap “Content Kind is Image” 
and “Content Kind is Video” in an 
ANY group.

• but you want to EXCLUDE folders 
from the results list, wrap “Content 
Kind is folder” in a NONE group. 
(For this example, you would get 
the same result if you simply set 
“Content Kind” to “IS NOT folder” 
instead of using a group.)

4.2.4. Find by Example
You can drag files from the HoudahSpot results list or from the Finder onto criteria in 
order to set them to match the file's properties. This comes in handy when looking for 
files that in one way or another resemble a file you have at hand.

Alternatively, you can use the “Match Selected Result” option from the context menu on 
a criterion.

Example: 
To find Microsoft Word files, drag a Word file onto a “Content type” criterion. The query 
will update to match all files of the Microsoft Word type.
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4.2.5. Snippets
Snippets hold either a single search criterion or a group of criteria that serve a certain 
purpose. A set of useful sample snippets is pre-installed. 

Insert a snippet by selecting it from the “Insert Snippet” item in the Search menu. You 
may also use the context menu (Control-click or right-click) in the Search pane. 
Alternatively, you can drag a Snippet from the Sidebar or from the Snippet preferences 
tab and drop it onto the criteria area of the Search pane.

To create a new snippet, select the criteria rows that make up your snippet in the Search 
pane, then either use the “Save as Snippet” command from the Search menu or make 
use of the context menu. To select the criteria rows more easily, hold the option key 
while you click.

The preferences tab allows for creating, deleting, exporting or importing snippets.

4.2.6. Temporarily Disable Criteria Rows
To disable criteria rows, select them, then either choose Search > “Disable Selected 
Criteria" from the menu or select “Disable” from the row’s context menu. To enable, 
select the respective rows and choose “Enable”  from the context menu or from 
HoudahSpot’s Search menu.

HoudahSpot relies on the Spotlight index to get file properties. For files not indexed 
by Spotlight, it can extract basic attributes only: name, date created, etc.

HoudahSpot 5: User Guide 16



4.3. Search Locations
In this section, you can configure the locations - folders or volumes - HoudahSpot is to 
search. By default, this will be your home directory.

Use the pop-up menu to choose from a selection of locations. Go to “Other...” to choose 
any other location.
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The search scope can also be configured by dragging files or folders onto rows in the 
locations section.

To organize the “Locations” and “Exclude Locations” pop-up menus, choose “Manage 
Locations...” from the Search Menu. In addition to your preferred locations, HoudahSpot 
will automatically list connected volumes and recently used locations.

To add a new location to the list, click the “+” button. The location will be added to 
“Locations” and “Exclude Locations” pop-up menus of your current search document. To 
remove a location from the menus, untick the “in Menu” checkbox.

If you want locations to show up in the pop-up menu of every new search document, 
click the “Update Menu in Default Setup”. To further customize the default setup, use the 
“Save as Default” command from the File menu.

HoudahSpot relies on the Spotlight index to find files and show file properties. As a 
rule of thumb, HoudahSpot can only find files in locations indexed by Spotlight. 

In some cases, HoudahSpot may be able to find files in folders excluded from 
Spotlight if you point HoudahSpot directly to such a folder. E.g. searching the folder 
~/Library/Preferences may find files that are not found when searching the parent 
folder ~/Library. In these directories, only searches by basic file properties (e.g. 
name) will work.
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4.3.1. Exclude Locations
You can exclude certain locations from the search. For instance, you may want to 
search all of your home folder, except for the Library folder. The setup would look like 
this:

HoudahSpot respects the most specific location listed.

Example:
A search within the User home folder and the folder ~/Music/iTunes with the whole 
Music folder excluded will search in the home folder and exclude the Music folder except 
for the iTunes folder within. Because ~/Music/iTunes is more specific than ~/Music, 
~/Music/iTunes takes priority over ~/Music.

4.4. Limit
You can choose to have HoudahSpot show only a limited number of results, e.g. the 
10’000 most recently opened or the 1’000 most recently modified files. Setting a limit 
keeps the results manageable and relevant.

Files may disappear from the list as the Spotlight engine finds “better matches”.
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4.5. Start / Stop Button
With HoudahSpot, searches start only when you are ready. Set up your query, then click 
the start button in the toolbar. Only now will HoudahSpot get busy gathering results. 

Once a HoudahSpot search has been started, it remains live even after gathering is 
completed. The results are updated as files are changed, added or removed from the 
system. You can still change the criteria to refine your search. As new files match the 
criteria, they are added to the results list.

4.6. Results
While the search is active, HoudahSpot shows found files on the right hand side of the 
window. Results can be displayed as a list or as a grid.

Control-click or right-click on the title row or use the Columns item in the View menu to 
add columns for other metadata attributes. You may sort results by any of these 
columns.
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Choose “More Columns …” to get the list of all column attributes available. Double click 
the row to add a column. Check the "In Menu" option to add a column without 
immediately using it.

If you want your selection for menu items to apply to every new search window, click the 
“Update Menu in Default Setup”. To further customize the default setup, use the “Save 
as Default” command from the File menu.

You can also arrange search results in groups by kind, date, file size, or application. For 
example: files that will open in Microsoft Word in one group, and files that will open in 
Apple Pages in another. The “Arrange By” option is available from the View menu. Like 
the column configuration and sort options, this setting is saved when creating a default 
setup or search template.

Select a file to see the path to its location at the bottom of the window. Command-
clicking a folder in the path narrows down your search to focus on the selected folder 
location. Command-Option clicking a folder adds its location to the excluded section. 
Double-clicking a folder in the path will open it in the Finder.

To see a file preview, select the file, then use the Quick Look menu item from the 
Results menu. To see a slideshow of previews from several result files, select these 
files and use the Slideshow menu item from the Results menu.
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4.6.1. Filter
You may also further narrow down your search results using the filter text field on the top 
of the Results pane. This allows you to filter – show or exclude – files where the name, 
path, file name, parent folder or any folder in the path matches text or a regular 
expression you enter in the filter field.

Filters help narrowing down search results. Use filters to see only a subset of the found 
files. Use filters to apply conditions that are not as easy to express as search criteria. 

For example, when you want to find all photos in folders named “vacation”, it is quicker 
to use filters than to list all of these folders as search locations. Just run a search for 
photos in your home folder. Then filter the results to see only photos where a parent 
folder is named “vacation”.

Regular expressions can be especially handy when filtering search results. Such filters 
allow, for example, to see only files whose name begins with IMG_ and is followed by a 
four-digit number and then the file extension: ^IMG_\d{4}\.\w* . For case-insensitive 
matching use: (?i)^IMG_\d{4}\.\w* .

4.6.2. File Actions
Once you have located the files you are looking for, you can:

• Double-click to open 
 
HoudahSpot will pass the first “text content” or “any text” search strings on to the next 
application. In many applications, you can then proceed to find the text in the 
document by hitting command-G. 

• Drag files to a Finder window to move or copy  
 
This can be a powerful technique for housekeeping.  
 
Examples: 

• You want to search for music files that are somewhere on your computer but not in 
the Music Folder. Set up a search for Music files and exclude the Music Folder 
location. Drag the files from the results list to your Music folder. 

• Should you want to organize your files by date, e.g. one folder for each month: 
create a search to match the files from a given month. In the Finder, locate or 
create the folder. Then drag all files from the results to that folder.
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• Drag files onto the Trash icon to delete them.

• Drag files to an application in the Dock to open them with the application selected.

• Rename files or assign Finder file tags by calling up the respective commands in 
the Results menu, from the Actions toolbar button or in the context menu (Control-click 
or right-click). 
 
Tagging behavior: Tags you add are added to all selected files. Tags you remove are 
removed where present. Tags you don’t touch are left unchanged. Files which had the 
tag keep it, files which didn’t have the tag still don’t have it. If you check the  “Replace 
existing tags” option, all selected files will get the exact set of tags shown.

• Apply actions from the Actions and from the Share toolbar buttons.

• Copy the list of results as text to use in another application. 
 
You can copy a list of selected files as text by selecting the “Copy as Tab Delimited” 
command from the Edit Menu. The copied text includes all columns currently displayed 
in HoudahSpot. You may also choose to copy File Names or File Paths only. The 
copied information can be pasted into text editors or spreadsheets.

Example:  
You may want to create a list of all your music titles. Create a search to match audio 
files from the “Music” folder. Enable the columns as desired: Title, Composer, Length, 
Size, etc. Now select rows from the results list and hit Command-Shift-C to copy. 
Paste to a text editor or spreadsheet.
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4.6.3. Details: File Info, Quick Look, Text Preview
To the right of the Results pane, you will find the Details pane. Use the buttons on the 
top right of this pane to switch between Info, Quick Look, and Text Preview.

The Info window shows all the 
metadata registered with the 
Spotlight index. These are the 
attributes you can use for searching. 

Tick the checkbox next to an 
attribute to filter your search results 
by this attribute.

The Info window is copy-paste 
enabled. Select a single attribute 
and hit Command-C to copy its 
value to the pasteboard. Select a 
range of attributes by holding the 
shift-key while clicking or select 
several attributes by Command-
clicking, then copy them using 
Command-C. A tab-separated list of 
the attributes selected will be 
created in the pasteboard.
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If you choose “File 
Info” from the 
Window menu, the 
File Info will open in a 
separate window.

Text Preview shows the file’s text 
content as submitted to the Spotlight 
index. Search terms are highlighted.

Arrows in the small toolbar above 
the text let you navigate between 
matches.

The fold / unfold button in the top 
right corner toggles between 
showing the full text and only 
showing text close to matched 
search terms.
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If you choose “Text 
Preview” from the 
Window menu, the 
Text Preview will open 
in a separate window.

The Details pane may be hidden by clicking the respective view 
selector button in the toolbar or by using commands from the View 
menu.

4.6.4. Saving Search Results as Text Files
You may save the search results list as tab delimited text file to be used in other 
applications like spreadsheets etc. Go to File > “Save Results to Text File”.
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5. Customizing Default & Using Templates

5.1. Saving Searches
HoudahSpot searches are documents. You can create or open as many documents as 
you like. You can run several searches at the same time. You can open a new document 
in a new window or in a tab within the same window. 

You can save HoudahSpot search documents for later use or for sharing with coworkers 
and friends.

HoudahSpot documents save every piece of information you entered: search criteria, 
search terms, view options, result columns, sort order, etc. HoudahSpot also remembers 
whether your search was active when you saved the document. If it was, the search will 
start immediately upon opening the document.

When a saved search document has been edited, HoudahSpot will ask on quit if you 
would like to save the changes or discard them.

5.2. Save as Default
“Save as Default” allows you to configure HoudahSpot to match your personal 
preferences regarding the setup of search criteria, locations, sort order, column, etc.

You can change the HoudahSpot default window layout by saving the current layout 
using the “Save as Default” command from the File menu. Your new default layout will 
then be used as the starting point for all new documents. 

To switch between your saved default and the factory default, go to the General tab in 
the Preferences pane.

HoudahSpot will not suggest to save untitled searches nor will it automatically save 
documents when you quit the application. It assumes that searches are disposable 
unless you tell it otherwise.
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5.3. Templates
Templates serve as starting points. Opening a template creates a new search. The 
actual template will not be affected by any changes you make to that document. A 
search created from a template is – just like a normal search – considered to be 
disposable.

Templates are available from both the “Templates” menu or the Sidebar. HoudahSpot 
comes preconfigured with a set of sample templates. 

To save the setup of your current search window as a template, use the “Save as 
Template” command in the file menu. When a template was saved while the search was 
active, the search starts immediately when you select the template.

5.4. Export as Finder Smart Folder
You can save HoudahSpot searches as Finder smart folders. Set up your query, then go 
to File > Export as Smart Folder. HoudahSpot saves your search criteria and locations 
as a smart folder. However, Finder does not support some of HoudahSpot’s options. 
Therefore, values for locations exclusion, filters, custom columns etc. are dropped. If you 
want to retain these values, you may choose HoudahSpot’s “Save as Template” option.

6. View Options

6.1. Search, Results & Details Pane
A HoudahSpot window can show one or more search documents. When multiple 
documents are open in a single window, the window shows a tab bar.

The HoudahSpot window has a toolbar with the following items:  
search field, start/stop button, view selector, action button and share button.

The view selector contains the following buttons:
 
• Hide/Show Search
• Show Results as List / as Grid
• Show/Hide Details
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The View options can also be found in the View menu. You will also find some additional 
options there: 

• Search > “Show Automatically”: Search pane automatically appears when the stop 
button is clicked.

• Search > “Hide Automatically”: Search pane automatically disappears when the start 
button is clicked.
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• Date format: choose between different date and time formats for the list view.
• Grid: Switch between Icons and Previews (where available) in Grid view.

The grid can also show relevant file information below the names. What information is 
shown depends on the file type. For mail messages, for example, HoudahSpot will show 
the sender and recipient. For photos, it will show resolution and EXIF info. The “File Info” 
option can be enabled from the View > Grid menu.

The Toolbar can be hidden using the “Hide Toolbar” command in the View menu.

6.2. The Sidebar
Along the left edge of the window, you can choose to have a sidebar 
displayed. This sidebar lists your search templates, snippets, and favorite 
tags. The sidebar is hidden by default and can be revealed using the “Show 
Sidebar” item from the View menu.

If you click on a template in the sidebar, a new search tab will open, set up as defined in 
the template chosen. 

You can drag snippets or tags from the sidebar into the Refine section. If you click on a 
snippet or on a tag in the sidebar, a new search tab will open, containing the default 
search layout plus a search criterion for the tag selected or the snippet search criteria 
respectively.

You can tag a file by dragging it onto the respective tag. Drag it onto “All Tagged Files” to 
tag it manually. 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6.3. Compact Mode
Compact Mode shrinks the window to show just the search results. This frees up screen 
space and makes it easier to drag files from HoudahSpot to other applications.

To enter Compact Mode, click the icon in the toolbar. To exit, click the button 
again or reveal the Search or Details pane.

While in Compact Mode, you can resize and reposition the HoudahSpot window. Next 
time you return to Compact Mode, the window will be positioned as you left it.
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7. HoudahSpot Preferences
The HoudahSpot Preferences can be accessed from the HoudahSpot menu.

7.1. General
The top set radio buttons allow you to switch between Factory Default and Saved 
Default. This option is grayed out as long as no default has been saved.

The next set of radio buttons lets you define where the insertion point should appear 
when opening a new search window.

Enable “Quit HoudahSpot when last window closes” if you want the application to close 
when you close its last window.

When “Check for updates on startup” is enabled, HoudahSpot will check for a new 
version when it is launched. Press “Check for Updates” to check manually for a new 
version of HoudahSpot.

7.2. Tags
Define a list of favorite tags which will 
show up in the sidebar. Use the “+” and 
“–” buttons to add or remove tags. Drag 
and drop to reorder.

The first 7 tags will be available for quick 
file tagging from the context menu on 
search results.

If you want to create a keyboard shortcut 
to a tag, press “Record Shortcut” and 
type the key combination you would like 
to associate with this tag. The keyboard 
shortcut can be used to quickly assign or 
remove the tag from selected search 
results.
 
Click the box if you want these favorite 
tags to show up first in all tag drop-down menus.
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7.3. Templates
All installed templates are listed here. If 
you want to create a keyboard shortcut to 
open a specific template, select the 
template, press “Record Shortcut” and 
type the key combination you would like 
to associate with this template. The 
Keyboard Shortcut will then show up next 
to the template.

To locate a template file on your hard 
drive, select the template and press 
“Reveal in Finder”. “Open Templates 
Folder in Finder” takes you to the 
Templates folder in Finder. If not already 
installed, “Install Sample Templates” will 
copy a set of sample templates to your 
templates folder.

To delete the selected template, click the “–“ button. 

You can reorganize templates by dragging these to the desired position in the list. You 
can add folders by clicking the “folder” button below the list. Folders show as sub-menus 
in the Templates menu.

7.4. Snippets
Snippets are a single search criterion or a 
group of criteria that serve a certain 
purpose. A set of default snippets is pre-
installed. If they are missing or have been 
deleted, you can reinstall them by 
pressing “Restore Default Snippets”.

To use a snippet, simply drag it from this 
snippet list to the Search pane.

To create a new snippet, select the 
criteria rows that make up your snippet in 
the Search pane, then either press the 
“+” button or drag the criteria rows onto 
the snippets list. Name or re-name 
snippets by double clicking them.
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You can discard snippets using the “–“ button (beware: cannot be undone!).

You may export or import snippets in order to share them with others. Double-clicking a 
snippet file will automatically add it to your snippets list.

7.5. Shortcuts
You can configure HoudahSpot 
to show an icon in the menu bar 
or to open at the press of a hot 
key. 

These features are provided by the 
“HoudahSpot Helper” application. When 
you enable the “HoudahSpot Helper”, it 
will keep running even after you quit 
HoudahSpot.

The HoudahSpot Search Bar lets you quickly start a new search. Click the HoudahSpot 
menu bar icon or press the assigned keyboard shortcut to open the Search Bar. Type 
your query and press Return to open HoudahSpot. Optionally, you can select a search 
template and specify if HoudahSpot should search Names, Text Content, or Any Text. 
This latest option matches the configuration of your default setup or the selected search 
template.
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7.6. Privacy
In order for HoudahSpot to be able to find 
and display search results from Apple’s 
Calendar, Reminders, Contacts, 
applications or your Photos, you will 
need to grant HoudahSpot access. To do 
so, click the respective “Request Access” 
button. 

HoudahSpot will need “Full Disk Access” 
to search certain folders that may contain 
private data. This includes the folder 
where Apple Mail keeps you messages. 
To grant HoudahSpot access, click the 
“Grant Full Disk Access” button and follow 
the instructions.

The “Open Privacy System Preferences” 
button takes you to the Security & Privacy 
pane within System Preferences. Here, 
you can grant or revoke permissions.

7.7. Extensions
Enable the Finder Extension to add a HoudahSpot button to Finder windows. This allows 
you to open a HoudahSpot window to search the current Finder window.

Enable the Quick Action to add a “Search with HoudahSpot” option to the context menu 
on folders in Finder.

Install plug-ins for third-party applications. These allow you to start HoudahSpot 
searches from these applications.
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8. Automate HoudahSpot
HoudahSpot integrates nicely with your automated workflows.

Use the custom URL scheme to start HoudahSpot searches from third-party tools like 
Butler, LaunchBar, or Alfred. Use AppleScript to access search results and build more 
advanced workflows.

8.1. URL scheme and third-party tools
The URL for starting a new search has the following format:

houdahspot4://search?q=QUERY&location=PATH&template=PATH

The parameters are:

1. q (or query): The search string. For example: "Houdah%20Software", "name:*.txt" or 
"tag:orange". This parameter is optional.

2. l (or location): The path of the folder to search. This parameter is optional and may 
be repeated

3. t (or template). The path of the template to use. This parameter is optional. The path 
to the template must include the .hstemplate extension. You may use a path relative 
to your home directory by prefixing with a tilde: "~/Library/Application%20Support/
com.houdah.HoudahSpot4/Templates/Sample%20Templates/
Apple%20Mail%20Messages.hstemplate"

You may use this to start HoudahSpot searches from third-party tools like Butler, 
LaunchBar or Alfred. 

Butler:
1. Open "Butler: Search Engines" preferences
2. Create and name a new "Search Engine"
3. Set the URL Prefix to "houdahspot4://search?q=" (without the quotes)

Note: No URL encoding needed for Butler 4.1 and newer.

LaunchBar:
1. In LaunchBar, select "Index" > "Show Index" 
2. Create and name a new "Search Template (UTF-8)"
3. Set the Template URL to "houdahspot4://search?q=*" (without the quotes)

Spaces and special characters in the URL parameters need to be encoded (see 
w3schools.com). The URL encoding for the space character is %20.
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Alfred:
1. In Alfred, go to "Features" > "Web Search"
2. Create and name a new "Custom Search" (UTF-8)
3. Set the "Search URL" to "houdahspot4://search?q={query}" (without the quotes)

8.2. AppleScript
HoudahSpot implements the following AppleScript commands:

search – start a new search
finder search – start a new search for the frontmost Finder window

You can access HoudahSpot search results after a search has completed. Please refer 
to the AppleScript dictionary for details on available commands and properties.

Example:

tell application id "com.houdah.HoudahSpot4"
set myLocations to {"/Applications"}
set myDocument to search "HoudahSpot" locations myLocations

repeat until search completed of myDocument
end repeat

set myResults to results of myDocument
set myCount to count of myResults

display dialog "Found " & myCount & " files"

set mySelection to selection of myDocument

if mySelection is not {} then
set myPath to path of first item of mySelection

display dialog myPath
end if

end tell
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8.3. MacOS Service
HoudahSpot provides three system wide services. These show – where applicable – in 
the Services submenu of all applications on your Mac.

• New HoudahSpot Search: Launches HoudahSpot and/or opens a new window
• Search in HoudahSpot: Starts a HoudahSpot search for the selected text
• Search Folders in HoudahSpot: Creates a new HoudahSpot search of the selected 

folder

Services can be enabled and assigned keyboard shortcuts in System Preferences > 
Keyboard > Shortcuts > Services.

9. Advanced Features

9.1. Raw Query
Select “Raw Query” from the Window menu to see the query created by HoudahSpot 
and passed on to the Spotlight engine in a separate window.

9.2. Advanced Uses of the Search Field
The search field at the top of a HoudahSpot window makes it easy to quickly start a 
simple search. If needed, you can then use additional criteria to refine your search. 
Typically, you will use the Refine pane below the search field to assemble criteria to find 
the exact files your are looking for.

The search field, however, can also be used to build more complex queries. It 
understands a simple yet powerful syntax. The basic expression has the following 
format:

attributeName:value
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This will search for files where the named attribute contains words prefixed with the 
provided value. You can add more expressions to refine the query. If you omit the 
attribute name, HoudahSpot will search all text attributes.

Examples:
• Houdah – Searches for files where any text attribute contains the prefix Houdah
• name:Houdah – Searches for files where any of the display names contains Houdah
• Houdah Software – Searches for files that contain both Houdah and Software

By default, HoudahSpot searches text attributes for word prefixes. You can do other 
searches by using the “*” wildcard in the value.

Example: 
• filename:*.txt – Searches for file names ending with .txt

By default, HoudahSpot searches are case insensitive and diacritics insensitive. You can 
append the following modifiers to your search to change this:
• c = case insensitive
• d = diacritics insensitive
• w = search for words

Example:
• name:"houdah"cdw - Case & diacritics insensitive search for words starting with 

“houdah” (= Default)

If at least one modifier is set, the default value (cdw) will be ignored.

Examples:
• name:"houdah"cw - Case insensitive (BUT diacritics sensitive) search for words 

starting with “houdah”
• name:"houdah"dw - Diacritics insensitive (BUT case sensitive) search for words 

starting with “houdah”

Different criteria can be combined using the boolean operators AND, OR, NOT. If no 
operator is specified, an AND operator is assumed: each criterion further restricts the 
query.

Examples:
• name:Houdah OR filename:Houdah – Searches both display names and file name
• name:Houdah NOT filename:Houdah – Files where the display name contains 

Houdah, but the file name does not
• filename:*.txt AND (Houdah NOT text:Houdah) – .txt files where any text attribute 

contains Houdah, but the actual text content does not
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When using numeric attributes, you can specify a comparison operator or a range of 
values:

• pixelwidth:1000 – Searches for images exactly 1000 pixels wide
• pixelcount:>=7000000 – Searches for images with at least 7000000 pixels
• duration:60-240 – Searches for files with a duration in the range of 60 to 240 seconds. 

Typically audio or video files

When working with date attributes, you can specify dates, date ranges or one of the 
predefined ranges:
• dateadded:yesterday
• datemodified:"last month"

Possible values are: 

Possible attribute names are:
• one of the short names listed below
• kind – a special short name with preset values listed below
• native Spotlight attribute names like kMDItemDisplayName, kMDItemContentType, 

kMDItemKind, etc.

Short names: HoudahSpot defines 150+ short names so you don’t have to remember 
native Spotlight attribute names. The most commonly used ones are:
• name – Searches display names
• filename – Searches file names
• date – Searches common date attributes: date created, date modified, date added, 

date due, etc.
• * – matches any text attribute except for text content
• ** or anytext– matches any text attribute. E.g. author, recipient, …
• tag – Searches both Finder and Open Meta tags

The full list of short names can be found in the Appendix.

HoudahSpot defines a number of kind values that help you search documents by kind 
without having to know about Uniform Type Identifiers.

The most commonly used ones are:
• kind:application – Searches for applications
• kind:folder – Searches for folders, volumes and mount points
• kind:spreadsheet – Searches for common spreadsheet file formats
• kind:wordprocessing– Searches for common word processing file formats
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lastmonth
today
tomorrow
yesterday
lastweek

"last week"
"last month"
lastyear
"last year"
nextweek

"next week"
"next month"
nextyear
"next year"
thisweek

"this week"
"this month"
 thisyear
"this year" 



The full list of kind values can be found in the Appendix.

Trying to memorize all of the above commands and shorthands is futile. Most often, it 
is easier to set up and refine a search by configuring criteria in the Refine pane. If 
you find yourself repeatedly doing similar searches, you may want to remember the 
shorthand for that (e.g. "name:Houdah date:thisWeek"). While learning the ropes of 
the search field, you may find it useful to observe the raw query HoudahSpot builds.
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10. Appendix: List of short search field attributes
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*  
**  
added  
album 
alpha  
altitude  
anytext 
aperture  
appmanaged  
architectures 
audience  
audiobitrate  
audioencodingappli
cation  
audiosamplerate  
author 
bitrate  
bitspersample  
bps 
by 
categories 
category 
channels 
chat 
city 
codec 
colorspace  
comment 
composer 
contact 
contactkeyword  
container 
contains 
content 
contentcreated  
contentmodified  
contributor 
copyright 
country 

coverage  
created  
creator 
date  
dateadded  
delivery 
description  
displayname  
dpi  
duedate  
duration  
editor 
email  
encodedby 
encoder 
encodingapplicatio
n  
exifversion  
exposure  
exposuremode  
exposureprogram 
exposuretime  
filename  
flash  
fnumber 
focallength  
font 
from 
fstop  
genre  
group  
headline  
height  
heightdpi  
id  
imname  
instructions 
instrument 
instrumentcategory 

instrumentname  
intext 
invisible  
isjunk 
ismidi  
iso  
key 
keysignature  
keyword  
keywords 
kind  
language  
lastused  
latitude  
layer 
location  
longitude  
lyricist 
mail  
make  
maxaperture  
media  
mediatype  
metering  
meteringmode  
model  
modified  
musicalgenre  
name  
organization  
orientation  
owner 
pageheight  
pages 
pagewidth  
phone  
phonenumber 
pixelcount 
pixelheight 

pixelwidth  
platform 
producer 
profile  
province  
publisher 
purchasedate  
recipient 
recordingdate  
redeye  
rights 
samplerate  
security 
securitymethod  
size  
source  
spotlightcomment 
starrating  
state  
stationery 
streamable  
subject 
tag 
tags 
tempo  
text 
theme  
time  
timesignature  
title 
to 
totalbitrate  
tracknumber 
url  
used  
version  
videobitrate  
wherefrom 
whitebalance  



11. Appendix: List of search field kinds

12. Further Information
For more information, check the HoudahSpot web site and sign up for our newsletter.

For tips & tricks, watch the Houdah Software blog at https://blog.houdah.com.
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alias 
application  
archive  
audio  
bookmark 
businessCard  
"business card" 
contact 
compressed  

directory 
diskImage  
"disk image" 
document 
email  
event 
folder 
font 
image  

mail  
message  
movie  
music 
pdf  
presentation  
sourceCode  
"source code" 
spreadsheet 

text 
todo 
vcard  
video  
webArchive  
"web archive" 
wordProcessing  
"word processing"

https://www.houdah.com/houdahSpot/
https://www.houdah.com/newsletter/
https://blog.houdah.com

